5mge revs to 2000k then to 0?

View previous topic View next topic Go down

5mge revs to 2000k then to 0?

Post by 73luxury on Mon Sep 15, 2014 1:59 am

my friend has a 1986 toyota cressida all stock A/T
recently replaced:
all gaskets on head
oil/coolant
fuses/relays
MAF
spark plugs
cam position sensor
adjusted TPS

Ive done some research on google and everyone has said that it could be the TPS, dirty fuel filter or clogged CAT. The car has no power at all, when I hit pedal and floor it it goes like 5mph and slllloooooowwwlly picks up. At idle I floor it and it reaches 2000rpm and goes back to zero.. NExt thing I will do is cut the cat out and replace the fuel filter. Oh and it gets really really hot like its about to overheat. maybe it can be a clogged cat. ANy help please, thanks in advance.



73luxury

Posts : 11
Join date : 2013-07-01

View user profile

Back to top Go down

Re: 5mge revs to 2000k then to 0?

Post by Juntao on Tue Sep 16, 2014 9:17 am

check all your intake piping and manifold ports for leaks. check the routing of all vacuum lines.  any leak in the intake setup will cause the engine not to run and or act weird.     check for any cracks or leaks.    also check air flow meter connection.    they'll run without tps.  and fuel pumps usually aren't a issue. especially since it runs a little bit.
avatar
Juntao
Admin

Posts : 51
Join date : 2013-02-26
Location : Everywhere

View user profile http://cressidaforums.forumotion.com

Back to top Go down

Re: 5mge revs to 2000k then to 0?

Post by Juntao on Tue Sep 16, 2014 9:21 am

ah, actually sounds like ur distributor is off a tooth. these engines run excellent if the bolt on the distributor is in the center of the guide. as long as your timing belt is correct. with the distributor centered on the guide bolt, the car should run. if you have to clock the distributor all the way to one side, then it's on the wrong tooth.
avatar
Juntao
Admin

Posts : 51
Join date : 2013-02-26
Location : Everywhere

View user profile http://cressidaforums.forumotion.com

Back to top Go down

Re: 5mge revs to 2000k then to 0?

Post by Falkon45 on Tue Sep 16, 2014 9:46 pm

Timing is off, Dizzy is off (5Ms don't have cam or crank position sensors). Try resetting those, and see what happens.

Falkon45

Posts : 9
Join date : 2013-02-27

View user profile

Back to top Go down

Re: 5mge revs to 2000k then to 0?

Post by 73luxury on Mon Sep 29, 2014 4:03 am

Juntao wrote:ah, actually sounds like ur distributor is off a tooth.  these engines run excellent if the bolt on the distributor is in the center of the guide. as long as your timing belt is correct.    with the distributor  centered on the guide bolt, the car should run. if you have to clock the distributor all the way to one side, then it's on the wrong tooth.        

yeah the dizzy is pretty off to one side, ill re-do when i have time and ill get back to you thanks!

73luxury

Posts : 11
Join date : 2013-07-01

View user profile

Back to top Go down

Re: 5mge revs to 2000k then to 0?

Post by 73luxury on Mon Sep 29, 2014 4:05 am

Falkon45 wrote:Timing is off, Dizzy is off (5Ms don't have cam or crank position sensors).  Try resetting those, and see what happens.

ill redo the timing and dizzy, what are the sensors in the dizzy called? because i replaced those and the teeth should have a magnetic force when they point at the sensor. ill get back to you thanks

73luxury

Posts : 11
Join date : 2013-07-01

View user profile

Back to top Go down

Re: 5mge revs to 2000k then to 0?

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum