Bad turbo seals?

View previous topic View next topic Go down

Bad turbo seals?

Post by Bender on Mon Jun 30, 2014 5:20 am

My 2jz burns alot of oil when running but makes good power still, doesn't overheat and oil pressure is always good. After investigating, I found a good bit of oil built up in the throttle body and intake manifold. Further investigation brought me to the cold side of the turbo which is where the oil starts building up. I think/hope a new turbo (which I planned on getting one eventually anyway) will solve all the smoking problems. Anyway I already have replacement valve seals and gaskets etc. It would be cool if I could just save them though. Tomorow I'm gonna do a compression test. I'm thinking if all the cylinders are good its def the turbo seals. Any two cents on the issue?
avatar
Bender

Posts : 7
Join date : 2014-02-26
Location : mcbh hawaii

View user profile

Back to top Go down

Re: Bad turbo seals?

Post by Push on Tue Jul 01, 2014 3:17 pm

blow by... What turbo setup are you on? 2jzge NA-T? or 2jzgte? Most likely the turbo.(s)
avatar
Push

Posts : 122
Join date : 2013-02-26
Age : 30
Location : Naperville, IL

View user profile http://www.youtube.com/pushtoyota

Back to top Go down

Re: Bad turbo seals?

Post by Bender on Tue Jul 01, 2014 4:11 pm

2jz na - t vvti. Stock except for metal head gasket and arp head studs. With a shitty emusa turbo running 15 lbs. I'm really hoping the toyota gods give me a break so I won't have to rebuild the motor.
avatar
Bender

Posts : 7
Join date : 2014-02-26
Location : mcbh hawaii

View user profile

Back to top Go down

Re: Bad turbo seals?

Post by Juntao on Thu Sep 18, 2014 12:11 am

has this setup ever ran good before or leaking upon first start.
avatar
Juntao
Admin

Posts : 51
Join date : 2013-02-26
Location : Everywhere

View user profile http://cressidaforums.forumotion.com

Back to top Go down

Re: Bad turbo seals?

Post by Bender on Tue Dec 02, 2014 3:15 pm

So it was a bad turbo after all. However after inspecting the hg I noticed rust in water jackets, I got a new rad.and I'm gonna run rust inhibitor through it The head was good.
avatar
Bender

Posts : 7
Join date : 2014-02-26
Location : mcbh hawaii

View user profile

Back to top Go down

Re: Bad turbo seals?

Post by kamesama980 on Thu Dec 04, 2014 6:47 pm

Keep in mind most turbos don't need that much oil to run. too much oil supply pressure or volume will cause leaks. Likewise insufficient or convoluted drainage will cause leaks.
avatar
kamesama980

Posts : 89
Join date : 2013-02-28
Age : 32
Location : Columbus, IN

View user profile

Back to top Go down

Re: Bad turbo seals?

Post by Bender on Sat Dec 06, 2014 2:32 am

On second thought,how bad for the block is to have rust in the water jackets?
avatar
Bender

Posts : 7
Join date : 2014-02-26
Location : mcbh hawaii

View user profile

Back to top Go down

Re: Bad turbo seals?

Post by RayRay on Mon Dec 08, 2014 4:44 am

99% of engines that come from japan have a fair bit of rust in the water jackets, and quite a few of them have a fair bit of pitting on the block's deck. I think they run shitty coolant or mostly water.. I dunno, In my experience it does wash away a little and tend to do a few coolant changes in close intervals the first little while. Its not that bad, as long as its not clogging up your rad/water pump/heater core... but that should be obvious.

RayRay

Posts : 114
Join date : 2013-04-29

View user profile

Back to top Go down

Re: Bad turbo seals?

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum